Search Members Help

» Willkommen Gast
[ Einloggen :: Registrieren ]

Alle Beiträge auf einer Seite

[ bei Antworten benachrichtigen :: per E-Mail senden :: Thema ausdrucken ]

reply to topic new topic new poll
Thema: SNTool 2.1.38 tut es leider nicht mehr< Älteres Thema | Neueres Thema >
 Beitrag Nummer: 1
TheHappyJoker Search for posts by this member.
Number One
Avatar

TeamIcon

Gruppe: Super Moderators
Beiträge: 62
Seit: 02.1.2006
PostIcon Geschrieben: 31.1.2009, 21:03  Skip to the next post in this topic. Ignore posts   QUOTE

Hallo Luke,

ich habe mir die neue Version von SNTool heruntergeladen, aber leider funktioniert jetzt garnichts mehr... :(

Egal ob mit Firefox 3, IE 7 oder Opera 9.6. Das Browserfenster scheint beim Klick in SNTool (seeehr) kurz inaktiv zu werden und leider wird kein BBCode in Textareas eingefügt. Im Grunde zeigt SNTool keine Auswirkung.

Habe sicherheitshalber auch schon die INI-Datei gelöscht, brachte aber keinen Erfolg.

System: Windows XP SP3

Könnte das an deinen neuen Timing-Einstellungen liegen?

<gruß thj>

Nachtrag:

Wie es scheint, bleibt SNTool auch im Speicher (ca. 10 MB), obwohl per X beendet.
Werde es am Montag nochmal auf einen anderen Rechner testen.


Bearbeitet von TheHappyJoker am 31.1.2009, 21:12
Offline
Top of Page Profile Contact Info WEB 
 Beitrag Nummer: 2
Luke_Filewalker Search for posts by this member.
Bastard Operator From Hell
Avatar

TeamIcon

Gruppe: Administrators
Beiträge: 891
Seit: 23.12.2005
PostIcon Geschrieben: 01.2.2009, 12:06 Skip to the previous post in this topic. Skip to the next post in this topic. Ignore posts   QUOTE


(TheHappyJoker @ 31.1.2009, 21:03)
QUOTE
Könnte das an deinen neuen Timing-Einstellungen liegen?

Muss wohl. :( Denn ich habe zum einen eine veraltete Pause-Routine durch eine moderne ersetzt die keinerlei CPU Last hat und zum anderen wegen dem Windows-Clipboard-Timing-Problem an zwei weiteren Stellen den Verzögerungsbefehl eingefügt. Werde ich austesten.

QUOTE
Wie es scheint, bleibt SNTool auch im Speicher (ca. 10 MB), obwohl per X beendet.

Holla! Das ist aber auch nicht normal. Werde ich ebenfalls testen. Aber das ist mir grad ein Rätsel, weil in der Richtung gabs keine Änderungen.

P.S.: Ich habe bei diesem Post übrigens mit SNTool gearbeitet.


Bearbeitet von Luke_Filewalker am 01.2.2009, 12:15

--------------
Luke 'GTH' Filewalker
...may the backup be with you - always!
Zitat: "Nicht gesicherte Dateien dürfen als gelöscht betrachtet werden"
Offline
Top of Page Profile Contact Info WEB 
 Beitrag Nummer: 3
Luke_Filewalker Search for posts by this member.
Bastard Operator From Hell
Avatar

TeamIcon

Gruppe: Administrators
Beiträge: 891
Seit: 23.12.2005
PostIcon Geschrieben: 01.2.2009, 12:11 Skip to the previous post in this topic. Skip to the next post in this topic. Ignore posts   QUOTE

Aaaah ich denke ich hab zum ersten Problem vermutlich gleich die Antwort. Kann es sein das Dein Timing Wert auf 0 steht? Ich hab diesen gerade mal bei mir auf 0 gesetzt und habe nun das gleiche Problem. Sonst steht der auf 50. Das mal bitte testen, wenn nötig auch mit höheren Werten. Sollte sich das in der Richtung bewahrheiten, werde ich den Standard von 0 auf 50 erhöhen müssen.

Ich habe übrigens ebenfalls Win XP Pro SP3.


--------------
Luke 'GTH' Filewalker
...may the backup be with you - always!
Zitat: "Nicht gesicherte Dateien dürfen als gelöscht betrachtet werden"
Offline
Top of Page Profile Contact Info WEB 
 Beitrag Nummer: 4
Stoffel Search for posts by this member.

Avatar

TeamIcon

Gruppe: Super Moderators
Beiträge: 23
Seit: 24.6.2007
PostIcon Geschrieben: 01.2.2009, 12:44 Skip to the previous post in this topic. Skip to the next post in this topic. Ignore posts   QUOTE

Grade nebenher getestet, im "Auslieferungszustand" das gleiche Verhalten wie bei TheHappyJoker.
Wenn ich den Timing-Wert auf 100 ändere funktionieren
die Formatierungen.

Den Verbleib im RAM nach korrektem Beenden kann ich
auch bestätigen, wenn auch "nur" mit rund 6 MB.

Grüße, Stoffel
Offline
Top of Page Profile Contact Info WEB 
 Beitrag Nummer: 5
Luke_Filewalker Search for posts by this member.
Bastard Operator From Hell
Avatar

TeamIcon

Gruppe: Administrators
Beiträge: 891
Seit: 23.12.2005
PostIcon Geschrieben: 01.2.2009, 13:01 Skip to the previous post in this topic. Skip to the next post in this topic. Ignore posts   QUOTE

Bisherige Erkenntnisse: Ok, so wie es aussieht, hängen beide Probleme mit den Timings zusammen. Wenn man z.B. das Timing auf 0 stellt, dann in SNTool eine Funktion auslöst und dann versucht SNTool zu beenden, bleibt SNTool im Speicher. Stellt man das Timing auf mindestens 1, kann SNtool nach einer Formatierung sauber beendet werden. Stellt man dann Timing auf einen höheren Wert - z.B. 50 hat sich ganz gut bewährt - dann funktioniert erstens SNTool wie es soll und wird zweitens auch komplett beendet beim schliessen.

Das alles mal bitte selbst ausprobieren und mitteilen, ob Du zum selben Ergebnis kommst. Ich hab jetzt jedenfalls genug Infos um weiter zu testen und die Probleme in den Griff zu bekommen. Aber vermutlich wirds darauf hinauslaufen, das Minimum von 0 auf wenigstens 50 anzuheben.

Ich bin mir jetzt ziemlich sicher, dass das Problem beim beenden mit der neuen WAIT Routine zusammen hängt. Offensichtlich hat die ein Problem damit, wenn ihr der Wert 0 übergeben wird. Normal denkt man eine Warte-Funktion wäre das simpelste was es gibt beim programmeren. Das gilt jedoch nicht, wenn man eine Warteschleife haben möchte, die keine CPU Last erzeugt. Ich verwende dafür direkt einen System Timer von Windows. Das ist also eine Windows eigene Methode. Mal schauen.


Bearbeitet von Luke_Filewalker am 01.2.2009, 13:03

--------------
Luke 'GTH' Filewalker
...may the backup be with you - always!
Zitat: "Nicht gesicherte Dateien dürfen als gelöscht betrachtet werden"
Offline
Top of Page Profile Contact Info WEB 
 Beitrag Nummer: 6
Luke_Filewalker Search for posts by this member.
Bastard Operator From Hell
Avatar

TeamIcon

Gruppe: Administrators
Beiträge: 891
Seit: 23.12.2005
PostIcon Geschrieben: 01.2.2009, 13:03 Skip to the previous post in this topic. Skip to the next post in this topic. Ignore posts   QUOTE

@Stoffel
Du hast gepostet während ich noch an meinem beschäftigt war. ;)

Interessant. Hast Du das Problem mit im Speicher bleiben auch dann, wenn der Wert auf 100 steht?

P.S.: Danke fürs mittesten.  :)


Bearbeitet von Luke_Filewalker am 01.2.2009, 13:05

--------------
Luke 'GTH' Filewalker
...may the backup be with you - always!
Zitat: "Nicht gesicherte Dateien dürfen als gelöscht betrachtet werden"
Offline
Top of Page Profile Contact Info WEB 
 Beitrag Nummer: 7
Stoffel Search for posts by this member.

Avatar

TeamIcon

Gruppe: Super Moderators
Beiträge: 23
Seit: 24.6.2007
PostIcon Geschrieben: 01.2.2009, 13:12 Skip to the previous post in this topic. Skip to the next post in this topic. Ignore posts   QUOTE

Okay, funktioniert wenn das Timing auf 50 steht!
War vorhin offensichtlich ein Anwenderfehler
- das von mir auf 100 geänderte Timing war auf 0
zurückgestellt. Vermutlich hab ich versucht zu ändern,
als der Prozess noch lief  :wall:
Offline
Top of Page Profile Contact Info WEB 
 Beitrag Nummer: 8
Luke_Filewalker Search for posts by this member.
Bastard Operator From Hell
Avatar

TeamIcon

Gruppe: Administrators
Beiträge: 891
Seit: 23.12.2005
PostIcon Geschrieben: 01.2.2009, 13:19 Skip to the previous post in this topic. Skip to the next post in this topic. Ignore posts   QUOTE


(Stoffel @ 01.2.2009, 13:12)
QUOTE
Okay, funktioniert wenn das Timing auf 50 steht!

Nochmal zum mitschreiben und um ganz sicher zu gehen. Es funktionieren sowohl Formatierungen als auch das komplette beenden wenn Du wenigstens 50 einträgst? Ist das so korrekt?

Aus meiner Vermutung bez. der WAIT Routine ist inzwischen ein Faktum geworden: Wird ihr der Wert 0 übergeben, wird der Hook den ich setze offensichtlich beim beenden nicht mehr gelöst. Deshalb bleibt auch ein Subtask von SNTool selbst noch im Speicher und wartet bis zum Sanktnimmerleinstag darauf, dass Windows den Hook wieder freigibt.


Bearbeitet von Luke_Filewalker am 01.2.2009, 13:59

--------------
Luke 'GTH' Filewalker
...may the backup be with you - always!
Zitat: "Nicht gesicherte Dateien dürfen als gelöscht betrachtet werden"
Offline
Top of Page Profile Contact Info WEB 
 Beitrag Nummer: 9
Stoffel Search for posts by this member.

Avatar

TeamIcon

Gruppe: Super Moderators
Beiträge: 23
Seit: 24.6.2007
PostIcon Geschrieben: 01.2.2009, 13:42 Skip to the previous post in this topic. Skip to the next post in this topic. Ignore posts   QUOTE


(Luke_Filewalker @ 01.2.2009, 13:19)
QUOTE
Nochmal zum mitschreiben und um ganz sicher zu gehen. Es funktionieren sowohl Formatierungen als auch das komplette beenden wenn Du wenigstens 50 einträgst? Ist das so korrekt?


Genau, beide Probleme behoben!
Offline
Top of Page Profile Contact Info WEB 
 Beitrag Nummer: 10
Luke_Filewalker Search for posts by this member.
Bastard Operator From Hell
Avatar

TeamIcon

Gruppe: Administrators
Beiträge: 891
Seit: 23.12.2005
PostIcon Geschrieben: 01.2.2009, 13:51 Skip to the previous post in this topic. Skip to the next post in this topic. Ignore posts   QUOTE

Ok. Dann habe ich hier eine Vorabversion zum testen.

Fix: SNTool bleibt im Speicher wenn Timing = 0. Lösung: In diesem Fall wird WAIT sofort wieder beendet.
Fix: SNtool macht gar nichts. Lösung: Bei zwei WAIT Aufrufen, wird jetzt 50 genommen wenn Timing = 0 ist.

Mit diesem Fix sollte es auch bei Dir wieder funktionieren Joker, wenn Timing auf 0 ist.


Bearbeitet von Luke_Filewalker am 01.2.2009, 13:52

Download Verbindung [ ZIP File ]
Anzahl von Downloads: 324

--------------
Luke 'GTH' Filewalker
...may the backup be with you - always!
Zitat: "Nicht gesicherte Dateien dürfen als gelöscht betrachtet werden"
Offline
Top of Page Profile Contact Info WEB 
 Beitrag Nummer: 11
TheHappyJoker Search for posts by this member.
Number One
Avatar

TeamIcon

Gruppe: Super Moderators
Beiträge: 62
Seit: 02.1.2006
PostIcon Geschrieben: 01.2.2009, 19:31 Skip to the previous post in this topic. Skip to the next post in this topic. Ignore posts   QUOTE

Hallo,

mensch, da schau ich mal nen Tag nicht rein, und schon so ne Diskussion. ;)

Deine Bugfix-Version funktioniert wunderbar! SNTool verlässt jetzt ganz sauber meinen RAM und reagiert auch bei Timing=0.

<gruß thj>
Offline
Top of Page Profile Contact Info WEB 
 Beitrag Nummer: 12
Luke_Filewalker Search for posts by this member.
Bastard Operator From Hell
Avatar

TeamIcon

Gruppe: Administrators
Beiträge: 891
Seit: 23.12.2005
PostIcon Geschrieben: 01.2.2009, 20:31 Skip to the previous post in this topic. Skip to the next post in this topic. Ignore posts   QUOTE

Hi

Na klar doch, ich schau ja normal täglich ins Forum. ;)

Okay, dann funktioniert das nun bei uns drei wie es soll. Weitere Tests ergaben auch bei mir keine Probleme mehr, selbst bei Timing=0 nicht. An den entsprechenden wichtigen 2 Stellen wird jetzt unabhängig vom Timing eine Pause gemacht mit jeweils 50 ms. Es sein denn, Timing ist != 0, dann wird der Timing Wert genommen. So bleibt das alles trotzdem flexibel.

Werde die neue Version hochladen. Danke euch für die Rückmeldungen. So kriegt man Probs ratzfatz behoben.  :)


Bearbeitet von Luke_Filewalker am 01.2.2009, 20:31

--------------
Luke 'GTH' Filewalker
...may the backup be with you - always!
Zitat: "Nicht gesicherte Dateien dürfen als gelöscht betrachtet werden"
Offline
Top of Page Profile Contact Info WEB 
 Beitrag Nummer: 13
Luke_Filewalker Search for posts by this member.
Bastard Operator From Hell
Avatar

TeamIcon

Gruppe: Administrators
Beiträge: 891
Seit: 23.12.2005
PostIcon Geschrieben: 01.2.2009, 22:16 Skip to the previous post in this topic.  Ignore posts   QUOTE

QUOTE
An den entsprechenden wichtigen 2 Stellen wird jetzt unabhängig vom Timing eine Pause gemacht mit jeweils 50 ms.

Entgegen dieser Aussage habe ich in der aktuell hochgeladenen Version an allen zeitkritischen Stellen eine Verzögerung drin. Diese jedoch nur mit 25 ms was mehr als ausreichend sein sollte.


--------------
Luke 'GTH' Filewalker
...may the backup be with you - always!
Zitat: "Nicht gesicherte Dateien dürfen als gelöscht betrachtet werden"
Offline
Top of Page Profile Contact Info WEB 
12 Antworten seit 31.1.2009, 21:03 < Älteres Thema | Neueres Thema >

[ bei Antworten benachrichtigen :: per E-Mail senden :: Thema ausdrucken ]


Alle Beiträge auf einer Seite
reply to topic new topic new poll